Alfa Romeo 4C Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
214 Posts
Discussion Starter #1
Hi guys,

I removed the floor mat and I noticed a bunch of holes in my carbon fiber tub.

specially on the passenger side. Perhaps I’m missing some of the plastic bump. Can anyone check their car and tell me?

thank you
103350
 

Attachments

·
Registered
Joined
·
214 Posts
Discussion Starter #7
I've come to the conclusion that I am missing these little rubber bump. Anyone knows what they are and where I can buy them?

Here's a picture I found.

 

·
Super Moderator
Joined
·
13,306 Posts
Don’t really understand.

First picture, are you referring to the mark on the vertical surface? Don’t really know what to make of this. Does your car have the eye bolt for a car-seat tether, or is this the hole for it (I cannot tell for sure from the picture).

“Rubber bump”? If you mean the little domes they are cf and cover the stud end of a screw going into the tub from below. They are glued on and can be released with careful application of a heat gun. The inboard one gets removed on each side for installation of the Sector 111 / Inokinetic harness (lap belt) solution for instance.

The other (large oval) rubber piece is a factory drain hole plug. That part should be available from Alfa.
 

·
Registered
Joined
·
214 Posts
Discussion Starter #9
Don’t really understand.

First picture, are you referring to the mark on the vertical surface? Don’t really know what to make of this. Does your car have the eye bolt for a car-seat tether, or is this the hole for it (I cannot tell for sure from the picture).

“Rubber bump”? If you mean the little domes they are cf and cover the stud end of a screw going into the tub from below. They are glued on and can be released with careful application of a heat gun. The inboard one gets removed on each side for installation of the Sector 111 / Inokinetic harness (lap belt) solution for instance.

The other (large oval) rubber piece is a factory drain hole plug. That part should be available from Alfa.
I believe the mark on the vertical surface is a screw hole. After checking other pictures, I believe that's normal. I'm talking about one of the rubber dome on the passenger side. Mine is basically a hole. There is no stud or rubber dome. I have no idea what happened or I should be fixing this.
 

·
Registered
Joined
·
758 Posts
You're missing the little rubber bumps.

Those are harness fixing points (yes, the 4C has them already drilled on the tub).
 

·
Registered
Joined
·
214 Posts
Discussion Starter #12
You're missing the little rubber bumps.

Those are harness fixing points (yes, the 4C has them already drilled on the tub).
Thank you friend. Is it the only little rubber bumps or there is a stud under it?
 

·
Registered
Joined
·
758 Posts
Thank you friend. Is it the only little rubber bumps or there is a stud under it?
Check this thread:





 

·
Registered
Joined
·
214 Posts
Discussion Starter #14
Check this thread:





Thank you. So I'm just missing the cap. I wonder if this is a special fastener or I can get it at some fasterner place.
 
1 - 14 of 14 Posts
Top