Alfa Romeo 4C Forums banner

21 - 40 of 79 Posts

·
Premium Member
Joined
·
1,057 Posts
Discussion Starter · #22 ·
I bolted the top first. I believe I ended up filing the bolt to a pointed head to get it through with a hammer, then ran a die over it to clean the threads. The bolt was pretty long there are plenty of threads to work with.
What concerns me is that to line up, something has to give and that will be those mounting points on the coilovers. The weak point is the welds and stainless isn’t great at absorbing stress or deforming. I would hate to lose a front leg on a fast corner or leave one behind because of a pothole jumping out in front of me.
 

·
Super Moderator
Joined
·
16,535 Posts
I bolted the top first. I believe I ended up filing the bolt to a pointed head to get it through with a hammer, then ran a die over it to clean the threads. The bolt was pretty long there are plenty of threads to work with.
If all else fails, get a bigger hammer?
:D
Obviously, it worked for you. I’d be concerned to try this approach, though. Especially now, knowing there might be a manufacturing issue that could resolve it without force.
 

·
Premium Member
Joined
·
1,057 Posts
Discussion Starter · #27 · (Edited)
I got another email from the garage today detailing discrepancies.
114068


The fronts are to spec and fit perfectly. Accept nothing less.
 

·
Premium Member
Joined
·
1,057 Posts
Discussion Starter · #28 ·
An update. KW told us that they have found the jig was modified incorrectly to overcome a weld issue or something like that.
So, they need to rebuild the jig before making me A third set! This will take another 3 to 4 weeks.
They offered me a refund if I want! after a month and a fortune in wasted garage time trying their faulty products and faulty replacements, I’m £3k down and counting with no 4C for ages. Buyers remorse takes on new meaning.
 

·
Registered
Joined
·
1,700 Posts
An update. KW told us that they have found the jig was modified incorrectly to overcome a weld issue or something like that.
So, they need to rebuild the jig before making me A third set! This will take another 3 to 4 weeks.
They offered me a refund if I want! after a month and a fortune in wasted garage time trying their faulty products and faulty replacements, I’m £3k down and counting with no 4C for ages. Buyers remorse takes on new meaning.
I should probably check mine out that I just received 2 days ago before attempting to install them.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
1,057 Posts
Discussion Starter · #31 ·
That’s interesting, and good news. I will be interested to hear how well they fit but glad yours seem fine. I wouldn’t wish this crap I’m going through with mine on anyone.

I reread the message and the inaccuracies on the 2 sets they sent us were due to distortion from welding, they say.

I suspect the truth is just random human error at some point in the setting up and tooling for the sets they made for me.
 

·
Premium Member
Joined
·
1,057 Posts
Discussion Starter · #32 ·
Just spoke to the workshop and the said the new coilovers are on their way. They gave more detail of what happened.
KW were trying to improve the welds appearance and it resulted in distortion.
They have had a number of sets returned, I am not the only person who had bad ones.

should have the 4C back before too long now. I’m telling myself a week tops :)
 

·
Super Moderator
Joined
·
9,037 Posts
Just spoke to the workshop and the said the new coilovers are on their way. They gave more detail of what happened.
KW were trying to improve the welds appearance and it resulted in distortion.
They have had a number of sets returned, I am not the only person who had bad ones.

should have the 4C back before too long now. I’m telling myself a week tops :)
Excellent updates, Floro. Thanks for communicating so thoroughly.
 

·
Premium Member
Joined
·
1,057 Posts
Discussion Starter · #34 · (Edited)
My 4C has been with the mechanics for two months now. Just sitting waiting for KW to correct their mistakes and send us replacements. The first replacements were still wrong and still waiting for another set.

I just spoke to the mechanics and they are calling KW again tomorrow to see where these replacements are after 3 more weeks.

If they don’t come though by the end of the week, I have to call time, get the front set off, put the factory suspension back, return the KW crap.
Then, I will make sure every detail of this experience and all the admissions of fault by KW, are made public on every relevant platform so people know how it goes with KW when they make a mistake - badly.

If that’s how it goes, I will get the mechanics to get an Ohlins kit and put them on.
At this point, I almost want KW to fail 😁
 

·
Super Moderator
Joined
·
16,535 Posts
I don't blame you, FLORO.
No point in wasting time wishing you could be driving your car, because some manufacturer cannot get their sh!t together.
I'm impressed by your patience up to now, frankly.
 

·
Registered
Joined
·
1,454 Posts
I don't blame you, FLORO.
No point in wasting time wishing you could be driving your car, because some manufacturer cannot get their sh!t together.
I'm impressed by your patience up to now, frankly.
Really disappointing as I short listed these as 'good potential option' if I went the Coil over route given that I like them on my JCW.
 

·
Premium Member
Joined
·
1,057 Posts
Discussion Starter · #37 ·
Yes I’m disappointed as I know the issue is an anomaly but the product is normally good.
The only reason I will jump ship is their handling of the situation which has been appalling till now. They have till Monday next week to deliver or refund.
I‘m happy for the many people who got KW without issue. Wish I could say the same.
 

·
Registered
Joined
·
1,700 Posts
Yes I’m disappointed as I know the issue is an anomaly but the product is normally good.
The only reason I will jump ship is their handling of the situation which has been appalling till now. They have till Monday next week to deliver or refund.
I‘m happy for the many people who got KW without issue. Wish I could say the same.
I’m actually planning on starting the install of mine tomorrow. Really hoping it goes well and they fit without issue.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
1,057 Posts
Discussion Starter · #39 ·
Hoping yours weren’t affected by the same issue.
I got an email yesterday. KW have completed the restoration of the process, rebuilt the jigs and are making my replacements which should arrive soon.
I hope to have better news in near future.
 

·
Registered
Joined
·
1,700 Posts
Hoping yours weren’t affected by the same issue.
I got an email yesterday. KW have completed the restoration of the process, rebuilt the jigs and are making my replacements which should arrive soon.
I hope to have better news in near future.
I finished the fronts this afternoon. Haven’t tackled the rears yet. I’ll keep you posted.


Sent from my iPhone using Tapatalk
 
21 - 40 of 79 Posts
Top