Alfa Romeo 4C Forums banner

1 - 20 of 92 Posts

·
Registered
Joined
·
354 Posts
Discussion Starter · #1 ·
Hi,

had my right rear coilover fail today... I think it was a novitec one...

cars on a tow truck heading home now...

Not a great week, the other cars off the road due to an incident involving road rage...

Deep breath... hopefully the coilover is fixable...

hugs
AP
 

·
Super Moderator
Joined
·
9,104 Posts
Hi,

had my right rear coilover fail today... I think it was a novitec one...

cars on a tow truck heading home now...

Not a great week, the other cars off the road due to an incident involving road rage...

Deep breath... hopefully the coilover is fixable...

hugs
AP
Is your other car a Hilux or a Fiat 500, so I can get a minds-eye picture? Sorry to hear about the coilover. Was it a spring failure, a seal or something else? You didn’t hit another median strip this time, did you? Hope she gets fixed more quickly than last time and at least it didn’t happen while going into turn 1 at Lakeside at full noise. 😲 Hope you’re OK Andrew. Glad you shared.
 

·
Registered
Joined
·
292 Posts
Hi,

had my right rear coilover fail today... I think it was a novitec one...

cars on a tow truck heading home now...

Not a great week, the other cars off the road due to an incident involving road rage...

Deep breath... hopefully the coilover is fixable...

hugs
AP
Ouch! hope its a small thing & she's back on the road ASAP.
Take care.
 

·
Registered
Joined
·
354 Posts
Discussion Starter · #5 ·
The other car is a full sized 4wd... a Range Rover sport... I was towing a caravan at the time... gcm around 5t...

Not sure of the exact failure yet... top Mount is still in place isn’t connected to the shock anymore... I suspect I either overloaded or unloaded the rear over a big bump... and either snapped the shaft of the shock or the shaft slipped out of the top Mount...

Still in the truck on the way home... 300km takes a while.. lol

Also very glad it didn’t happen at lakeside... would probably have resulted in a very big accident.. and loss of the car...

Andrew


Sent from my iPhone using Tapatalk
 

·
Super Moderator
Joined
·
9,104 Posts
The other car is a full sized 4wd... a Range Rover sport... I was towing a caravan at the time... gcm around 5t...

Not sure of the exact failure yet... top Mount is still in place isn’t connected to the shock anymore... I suspect I either overloaded or unloaded the rear over a big bump... and either snapped the shaft of the shock or the shaft slipped out of the top Mount...

Still in the truck on the way home... 300km takes a while.. lol

Also very glad it didn’t happen at lakeside... would probably have resulted in a very big accident.. and loss of the car...

Andrew


Sent from my iPhone using Tapatalk
It could have been nasty. The car is ok and you’re ok and that’s what matters most. Just time and a little money will see things right. (y)
 

·
Registered
Joined
·
354 Posts
Discussion Starter · #7 ·
It could have been nasty. The car is ok and you’re ok and that’s what matters most. Just time and a little money will see things right. (y)
Agreed...
Just got it off the tilt tray... it looks like the shaft has failed on the shock...

:-(


Sent from my iPhone using Tapatalk
 

·
Super Moderator
Joined
·
9,104 Posts
Agreed...
Just got it off the tilt tray... it looks like the shaft has failed on the shock...

:-(


Sent from my iPhone using Tapatalk
I hope you get an explanation of why from someone knowledgeable on the subject. Will you get a new shock or repair it?
 

·
Registered
Joined
·
354 Posts
Discussion Starter · #9 ·
I hope you get an explanation of why from someone knowledgeable on the subject. Will you get a new shock or repair it?
Don’t know yet... on all fronts...

Concerned as I was driving down a straight bit of road at 100kph when it failed... admittedly it was a little rough... but just like any back country highway out here...

Will most likely be asking for assistance from the shock manufacturer as well... is it shouldn’t have failed...

Right now I’m exhausted... and it will be tomorrow’s problem... really bad week


Sent from my iPhone using Tapatalk
 

·
Super Moderator
Joined
·
9,104 Posts
Don’t know yet... on all fronts...

Concerned as I was driving down a straight bit of road at 100kph when it failed... admittedly it was a little rough... but just like any back country highway out here...

Will most likely be asking for assistance from the shock manufacturer as well... is it shouldn’t have failed...

Right now I’m exhausted... and it will be tomorrow’s problem... really bad week


Sent from my iPhone using Tapatalk
Rest well. Things will seem a little better in the morning.
 

·
Registered
Joined
·
298 Posts
Very unfortunate news to hear bud. At least you‘re in 1 piece.
You have me worried now. I have purchased Novitec corsa coil overs.
The black series has a slightly firmer spring.
Please keep us updated how it failed and if Novitec come to the party and replace.
Cheers mate
 

·
Registered
Joined
·
233 Posts
Very unfortunate news to hear bud. At least you‘re in 1 piece.
You have me worried now. I have purchased Novitec corsa coil overs.
The black series has a slightly firmer spring.
Please keep us updated how it failed and if Novitec come to the party and replace.
Cheers mate
Same here, got Corse+ black series coilovers on order and reading this is a bit worrying! They are manufactured by KW which is a reputable brand though, and I guess OEM shocks are not immune from failing either
 

·
Registered
Joined
·
354 Posts
Discussion Starter · #13 · (Edited)
So wheel is off...

they are novitec black...

the top of the shock shaft has unscrewed out of the top mount...

threads are damaged on both the top rubber mount and the shock shaft...

Hmmm

ap
 

·
Super Moderator
2015 4C Launch Edition
Joined
·
5,064 Posts
Make sure you let us know when they identify what caused it and what the manufacturer did (if on warranty). That is worrisome to hear. Hope you didn't identify a problem that might be an issue to other owners of that brand of coil overs.
 

·
Registered
Joined
·
658 Posts
Hi,



Not a great week, the other cars off the road due to an incident involving road rage...



hugs
AP
113605


Did you win afterwards? ;)
Joking aside....KW suspension is a reputable brand. They should NOT pass on this...Good luck!
 
  • Like
Reactions: Alfanut

·
Super Moderator
Joined
·
9,104 Posts
How old are they/how many miles are on them?
Just in case acp is away working on his car, they are a little more than twenty months on his car and distance travelled would be limited...Covid, other wanderings and such.... Hoping acp responds promptly.
 

·
Registered
Joined
·
354 Posts
Discussion Starter · #18 ·
Ok... so got it up and wheel off....

Shock had unscrewed from the top...

Pictures telling the story... note not all damage captured... :-(










Cleaned the threads on the top of the shock and the top Mount(via the right sized tap and thread file... in stock at dads place... )

Cleaned a burr off the spring collar... and put some lock tite on the thread and screwed it’s on...

Not sure how I feel about it all yet... definitely not happy...

But it’s back on all 4 wheels...

Even did a rough camber check...

Just have to tighten Everything up and put the wheel liner back in...

I’ve done a visual inspection of the left hand side rear and it looks ok...

More to follow...

Hugs
Ap


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
354 Posts
Discussion Starter · #19 ·
How old are they/how many miles are on them?
~18 months on the car June 2019
Probably 15,000km max

As you can see from the photos it has been loose for a while just going by the rust on the thread...


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,178 Posts
Sorry to read this acp, hope that it's just cosmetic damage.

I have this image of Mansell at the Adelaide GP in 1986 struggling to bring his car to a halt and imagined that it may have felt like that for you as you tried to bring your 4C back under control.


Cheers,

Alf.
 
  • Like
Reactions: Rbware
1 - 20 of 92 Posts
Top