Alfa Romeo 4C Forums banner

21 - 40 of 41 Posts

·
Registered
Joined
·
943 Posts
If it helps at all, when I had my last oil change in November 2018, they did a transmission update. Mine is a 2015 and apparently had not had a transmission update up till that point. Alfa volunteered the info and the flash.
 

·
Super Moderator
Joined
·
13,675 Posts
Low charge, bad terminal connections, and failing batteries have caused a lot of the issues described. It sounds like you are on the right track. A replacement battery is cheap and quick compared to an unknown transmission issue. Both should be covered by warranty, but fingers crossed that this is just an under-volt condition.
 

·
Registered
Joined
·
617 Posts
When I had my Carrera S with a PDK, It had all sort of issues with the transmission when the battery was bad. These dual clutch transmissions are heavily dependent on good batteries.
 

·
Registered
Joined
·
18 Posts
This happened again but this time just 1-3 and 5 would engage... I am having the dealer looking at it on Friday..could this still be related to a low voltage issue?
 

·
Registered
Joined
·
87 Posts
This happened again but this time just 1-3 and 5 would engage... I am having the dealer looking at it on Friday..could this still be related to a low voltage issue?
Hello WeekendFun,
We are certainly sorry to hear about your ongoing concern. Please keep us updated on your dealer findings. If we can be of any assistance, feel free to send us a private message. We'd be glad to help.
Laura
AlfaRomeoCares
 

·
Super Moderator
Joined
·
13,675 Posts
Gears 1-3-5 no manual option available
That sounds more serious.
There have been similar issues in a few cars - I think it was the gear selector mechanism inside the transmission that was to blame IIRC.
Unfortunately, I don't know how to find those threads / posts. It's been a while.

@The Real Cvh , is this similar to what you had with your first car?
 

·
Registered
Joined
·
3,394 Posts
If I remember correctly, just once, and leaving the car off for a while cleared it. I had a bigger issue with the “Change Engine Oil” light, which Pogea managed to help me sort out, because Alfa was unable to
 

·
Super Moderator
Joined
·
13,675 Posts
Found the other one that I was searching for.

Bummer! I am awaiting the result of the disassembly of the transmission in mine, so they can have a look at the clutches. It made the same thing, so I could only shift between 2, 4 & 6.

I should have it back next week and hope to get some info on what has been done to it...

@alfan, can you add anything to the discussion for our friend?

Thanks.
 

·
Registered
Joined
·
733 Posts
I had the same thing multiple times. Ended up having to change the actuator, which solved the problem.
My mechanic never got to the point finding out whether a broken actuator made the gearbox throw error codes, or the gearbox itself was broken. There is no way to tell.
Would be interested in hearing from @alfan his experiences!

Now, 20.000 kms later, I have a completely ruined transmission, with broken gear, broken actuator and broken TCU... So maybe it was the gearbox after all?
Car is at an official dealership as Alfa Romeo wants to consider intervening in the cost. Fingers crossed.

In the meantime, becoming crazy without my precious. Waiting for 2 months already...
 

·
Super Moderator
Joined
·
13,675 Posts
I had the same thing multiple times. Ended up having to change the actuator, which solved the problem.
My mechanic never got to the point finding out whether a broken actuator made the gearbox throw error codes, or the gearbox itself was broken. There is no way to tell.
Would be interested in hearing from @alfan his experiences!

Now, 20.000 kms later, I have a completely ruined transmission, with broken gear, broken actuator and broken TCU... So maybe it was the gearbox after all?
Car is at an official dealership as Alfa Romeo wants to consider intervening in the cost. Fingers crossed.

In the meantime, becoming crazy without my precious. Waiting for 2 months already...
"Liked" for the information, not the trouble you've had.

I knew there was another one, but couldn't remember who it was. Really sorry to hear it is still ongoing.

Hope you get your car back soon, and that Alfa helps out with the cost. If it is any consolation, my car has been in (my) garage for almost 3 months now due to winter. So I feel your pain.
At least you'll have the better part of a new drive train out of the ordeal.
 

·
Registered
Joined
·
180 Posts
Found the transmission thread, 'Inconsistent problems'.

My first post is #346 and then I have a few posts after that with the resolution.

I recommended contacting your dealer and get them to look at it right away!

I can see that AlfaRomeoCares have responded in this thread, hopefully they can assist here, as the garage might not know exactly what to do...
 

·
Registered
Joined
·
18 Posts
Hello WeekendFun,
We are certainly sorry to hear about your ongoing concern. Please keep us updated on your dealer findings. If we can be of any assistance, feel free to send us a private message. We'd be glad to help.
Laura
AlfaRomeoCares
Thank you for your reply - it is very comforting . I am working closely with Jim at Alfa Romeo Boston. He is very attentive and we exchanged a few phone calls. My car is still at the dealer (since Friday 1/31) as they are waiting to find out what might solve the issue. I made them aware of your comment on this Forum and of your willingness to help if the need might arise.
I will keep this thread updated with the findings. If there is anything you would like me to convey to them please let me know.
Best
 

·
Registered
Joined
·
87 Posts
Thank you for your reply - it is very comforting . I am working closely with Jim at Alfa Romeo Boston. He is very attentive and we exchanged a few phone calls. My car is still at the dealer (since Friday 1/31) as they are waiting to find out what might solve the issue. I made them aware of your comment on this Forum and of your willingness to help if the need might arise.
I will keep this thread updated with the findings. If there is anything you would like me to convey to them please let me know.
Best
Hello WeekendFun,
Thank you for touching base here.We are happy to hear your dealer is helping you work towards a resolution. However, please know we are available if needed.
Laura
AlfaRomeoCares
 

·
Registered
Joined
·
18 Posts
Hello Laura,
i got a phone call from Alfa Romeo Boston. They confirmed that the TCM needed to be rebooted and the connections needed to be checked. They put some miles on the car to test it. I am kind of worried about the whole thing since no parts have been replaced and my warranty will end soon. I tried to contact Alfa Romeo Cares about the possibility of having a better deal for a warranty but the person on the phone Diaonara (sp?) just provided me some sort of cookie cutter answer, so i cut it short.
The service person Jim has been really professional, as mentioned the only issue is that no parts have been replaced. So the car has been there for more than 10 days for that. I love Alfa Romeo, and I consider my self an enthusiast - I truly hope we can work something out.
Thank you Laura,
have a great day
 

·
Super Moderator
Joined
·
5,445 Posts
Hello Laura,
i got a phone call from Alfa Romeo Boston. They confirmed that the TCM needed to be rebooted and the connections needed to be checked. They put some miles on the car to test it. I am kind of worried about the whole thing since no parts have been replaced and my warranty will end soon. I tried to contact Alfa Romeo Cares about the possibility of having a better deal for a warranty but the person on the phone Diaonara (sp?) just provided me some sort of cookie cutter answer, so i cut it short.
The service person Jim has been really professional, as mentioned the only issue is that no parts have been replaced. So the car has been there for more than 10 days for that. I love Alfa Romeo, and I consider my self an enthusiast - I truly hope we can work something out.
Thank you Laura,
have a great day
Many have had their transmission issues solved satisfactorily with a reflash....but I understand your reason for being nervous. I hope it’s all that’s needed.
 

·
Registered
Joined
·
87 Posts
Hello Laura,
i got a phone call from Alfa Romeo Boston. They confirmed that the TCM needed to be rebooted and the connections needed to be checked. They put some miles on the car to test it. I am kind of worried about the whole thing since no parts have been replaced and my warranty will end soon. I tried to contact Alfa Romeo Cares about the possibility of having a better deal for a warranty but the person on the phone Diaonara (sp?) just provided me some sort of cookie cutter answer, so i cut it short.
The service person Jim has been really professional, as mentioned the only issue is that no parts have been replaced. So the car has been there for more than 10 days for that. I love Alfa Romeo, and I consider my self an enthusiast - I truly hope we can work something out.
Thank you Laura,
have a great day
Hello WeekendFun,
I appreciate you touching base with me here. I certainly understand your sentiments expressed and your frustration associated with your situation. If you could please reach out to us privately with your VIN, I can try taking a further look into this from our end. We hope to hear from you soon!
Laura
AlfaRomoeCares
 

·
Registered
Joined
·
18 Posts
Thank you I have sent you a private Message.

Hello WeekendFun,
I appreciate you touching base with me here. I certainly understand your sentiments expressed and your frustration associated with your situation. If you could please reach out to us privately with your VIN, I can try taking a further look into this from our end. We hope to hear from you soon!
Laura
AlfaRomoeCares
 
21 - 40 of 41 Posts
Top