Alfa Romeo 4C Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Soooo...

Per title one of my headlamp units has gone wrong.

The 5 small LED's have all stopped working. On that basis I'm wondering if there is a main driver module for these lights? I doubt a fuse has blown. But it is possible. I have no error message on the dash.

The indicator and dip/main light works OK.

Anyone else had this problem? Anyone have a fix?

Thanks!
 

·
Super Moderator
4C SE, Giulietta Vel, 147, Sud, Guzzi 1100 Sport, Guzzi Le Mans MkV
Joined
·
12,650 Posts
@4CMEISTER , Are you using a VPN or holidaying in Thailand? Could you show us a photo demonstrating the problem? Just trying not to have anyone waste their time. When my 147 lights stop working…the right front parker just stopped the other day, a warning light and message showed up on the dash. It turned 20 last November. Of course no one has a H6W 12V halogen bayonet in stock, so I’m awaiting a delivery. I ordered two. I know my luck. Yeah, I should have ordered three.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
@4CMEISTER , Are you using a VPN or holidaying in Thailand? Could you show us a photo demonstrating the problem? Just trying not to have anyone waste their time. When my 147 lights stop working…the right front parker just stopped the other day, a warning light and message showed up on the dash. It turned 20 last November. Of course no one has a H6W 12V halogen bayonet in stock, so I’m awaiting a delivery. I ordered two. I know my luck. Yeah, I should have ordered three.

Hi

Here's a pic.

It's a the 5 small LED's that are not coming on. Not all 5 can fail at the same time!

There must be some kind of module that controls these lights.

Tx!

Car Automotive parking light Vehicle Automotive tail & brake light Grille
 

·
Super Moderator
4C SE, Giulietta Vel, 147, Sud, Guzzi 1100 Sport, Guzzi Le Mans MkV
Joined
·
12,650 Posts
Can you show us both sets of lights ie the whole front of the car….No warning lights if the daytime lights fail seems strange to me. @lars, I think, has seen the back of his lights so maybe able to confirm if there’s a control module hiding there. I would imagine so. Have you checked the e-manual for diagrams and photos? Here’s a link to the cloud. The e-manual is in one of the folders. Just look.
OneDrive
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #8 ·
Yes there is its a brain from pella, and it is a module
Can you elaborate on this module?

Here is a pic of each light. My main/dip works as does the turn signal. As I said, the 5 LED's on my N/S unit are not working.

No warning light on dash. Maybe the connector is indeed loose. I gave it a light thump to no avail. As all five are out then I'm thinking maybe loose wiring. These small LED's cannot draw much current. But if there is a module then a component may have failed.

It's strange that no one else has had this issue.

I will assume checking the wiring will mean removing the front hood.

Automotive parking light Automotive tail & brake light Car Vehicle Grille
Automotive parking light Vehicle Car Hood Automotive lighting
 

·
Super Moderator
4C SE, Giulietta Vel, 147, Sud, Guzzi 1100 Sport, Guzzi Le Mans MkV
Joined
·
12,650 Posts
This is very useful. Thank you.

I'm wondering if the LED's are wired in series or parallel. So one fails and they all go out like christmas tree lights.

That aside I agree best course of action is L to R substitution..
Do they have their own separate earth wire? If so, it could be loose and could explain why a light fault warning isn’t showing on the dash.
 
1 - 14 of 14 Posts
Top