Alfa Romeo 4C Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter · #1 ·
So after picking up the car last June/July with 22,000km (2015 car), I'm now just a few hundred kms off 40,000kms. I will pass that total on Sunday, as I'm driving out to Warwick for a show & shine and Happy Laps at Morgan Park. The last official service was this time last year and I've got it booked in on the 5th October. I've just had the 'change oil' warning come up on the dash. The car has been good as gold really, I've still got a small electrical gremlin with the windows but apart from that it hasn't missed a beat. Bolt tightening, water pump and belts were done back in Feb so the next service is really only a minor one. I wouldn't mind them looking at the usual points of failure - ball joints etc to see how they are travelling but anything else anyone can recommend that's worth a lookover would be helpful. I am trying a new independent service centre as my previous Alfa mechanic retired :(
 

·
Super Moderator
4C SE, Giulietta Vel, 147, Sud, Guzzi 1100 Sport, Guzzi Le Mans MkV
Joined
·
12,650 Posts
So after picking up the car last June/July with 22,000km (2015 car), I'm now just a few hundred kms off 40,000kms. I will pass that total on Sunday, as I'm driving out to Warwick for a show & shine and Happy Laps at Morgan Park. The last official service was this time last year and I've got it booked in on the 5th October. I've just had the 'change oil' warning come up on the dash. The car has been good as gold really, I've still got a small electrical gremlin with the windows but apart from that it hasn't missed a beat. Bolt tightening, water pump and belts were done back in Feb so the next service is really only a minor one. I wouldn't mind them looking at the usual points of failure - ball joints etc to see how they are travelling but anything else anyone can recommend that's worth a lookover would be helpful. I am trying a new independent service centre as my previous Alfa mechanic retired :(
Oh, “got IT booked IN on”, not “got booked on”. Wondered why you sounded pleased….Seriously, great news and glad we have people who enjoy driving their 4C more than looking at it. Keep us informed of the inspection outcome. It all helps. 👍
 

·
Super Moderator
4C SE, Giulietta Vel, 147, Sud, Guzzi 1100 Sport, Guzzi Le Mans MkV
Joined
·
12,650 Posts
Haven't had a speeding ticket yet!
I keep saying that…I keep waiting for letters but I think they’ve lost my address. 😉 Good luck rather than good management in my case. I’ve got witnesses. 😂 Hope it stays that way for both of us.
 

·
Registered
Joined
·
1,497 Posts
Good to see you are clocking up some km's in your 4C @scratchyratface.
You may have already tried this, but I will mention it anyway; if you are having issues with your electric windows, it can be caused if the battery voltage has got low, or has been disconnected. If this is the case, the car forgets the fully up position of the windows. After reconnecting the battery, the windows need to be run fully down and then fully back up again before starting the car for the computer to relearn the positions.
Hope that helps.
Cheers,
Alf.
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #7 ·
Thanks Alf, I had the battery replaced after inheriting the window issue but unfortunately that didn't fix it. When you get in the car and start the ignition, neither window will operate. You have to switch the car off and back on again. Have replaced the window switch module in the centre console as well but no difference. Sometimes it's both windows affected and other times it's just one :unsure:
 

·
Super Moderator
4C SE, Giulietta Vel, 147, Sud, Guzzi 1100 Sport, Guzzi Le Mans MkV
Joined
·
12,650 Posts
Thanks Alf, I had the battery replaced after inheriting the window issue but unfortunately that didn't fix it. When you get in the car and start the ignition, neither window will operate. You have to switch the car off and back on again. Have replaced the window switch module in the centre console as well but no difference. Sometimes it's both windows affected and other times it's just one :unsure:
That’s character! 😉😢
 

·
Registered
Joined
·
1,497 Posts
Thanks Alf, I had the battery replaced after inheriting the window issue but unfortunately that didn't fix it. When you get in the car and start the ignition, neither window will operate. You have to switch the car off and back on again. Have replaced the window switch module in the centre console as well but no difference. Sometimes it's both windows affected and other times it's just one :unsure:
That sucks
 
1 - 10 of 10 Posts
Top