Alfa Romeo 4C Forums banner
41 - 51 of 51 Posts

·
Registered
Joined
·
1,386 Posts
Sorta on topic regarding the TPMS. None of my four sensors indicated low pressure (all have consistently indicated "OK"). But I checked the pressures with an accurate gauge yesterday, and all four tires were 5 psi low. The sensors in my wheels (3/15 build date) are definitely not too sensitive.
Jim
only way to reset the pressure in the system is at the dealer
but then they will adjust it with their gauge, not yours
 

·
Registered
Joined
·
874 Posts
so I cycled the key a few times ( 5 times to be precise) cleared the error light on dash and the TPMS shows " --" next to each wheel :)


YAYYYY
 

·
Registered
Joined
·
115 Posts
SOLVED "TPMS not available"

As the days are getting longer up here (Sweden) and I use DRL instead of the headlights, the TPMS problem has disappeared...!

My non-OEM LED headlight bulbs interfered with the tyre monitoring signal...
 

·
Registered
Joined
·
1,745 Posts
...so do we have to buy ALFA TPMS sensors for a second set of wheels or is there a good aftermarket alternative?
TIA


Any will work. Although they’re pointless on this car. I didn’t even bother to install them on my aftermarket wheels.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
3,994 Posts
...so do we have to buy ALFA TPMS sensors for a second set of wheels or is there a good aftermarket alternative?
TIA

They’re not necessary but I like having them for added safety even on my track wheels with slicks. You can ruin a good tire very quickly if you lose air pressure not to mention the safety you gain.
I used Advan2 wheels and initially we tried aftermarket ones from Matt at Alfa9 and they did NOT work. We switched them for OEM sensors and they worked fine. I would not use anything other than the OEM ones.
 

·
Registered
Joined
·
768 Posts
Is there a way to clear the TPMS or TPMS unavailable light on the dash if I am not running TPMS on aftermarket wheels?
is this still not viable ? looking to see if my code can be turned off during my service?
 

·
Super Moderator
Joined
·
9,654 Posts
is this still not viable ? looking to see if my code can be turned off during my service?
Why worry about it? My track wheels don’t have sensors and the dash warning light is in such a position that I rarely see it as it’s obscured by the steering wheel rim.
 

·
Registered
Joined
·
768 Posts
Why worry about it? My track wheels don’t have sensors and the dash warning light is in such a position that I rarely see it as it’s obscured by the steering wheel rim.
Also true aha


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
306 Posts
wow
I finally figured out a fix!
I have always had the pressures set to what it says on the door jamb
26 psi front, 29 rear
I have had that tire pressure system unavailable error for ages
took it to 2 dealers, 4 vists, neither one was able to fix it
they reset the system, which makes the error go away, but it always came back

the other day, for shits and giggles, I adjusted all 4 tires to 40 psi
damn uncomfortable but I thought I would give it a try
the next day when I first started up the car
I did not get the blinking TPMS error!
I dropped the pressure to 30 front, 32 rear
and the light is still off
so I think RacerZ is correct
the door jamb might say 26/29. but the ecu is set to a different pressure
ecu needs more than 26/29, not sure yet how much
will try lowering them to 28/31 and see

the weird thing is , I have gotten once that the right front tire was low on the dash, and it was marked in red
so what causes the system to sometimes say one tire is low?
and other times to just say system unavailable for all the tires??

I do know the TPMS system on the alfa sucks
never seen a TPMS system where you could not reset the pressures yourself
every car I have owned, you could adjust the pressures to your liking, then click reset
and that becomes your new baseline
on the alfa that baseline is set at the dealer, and you have no way of knowing what it is, or resting it
Was having a problem with the tire low pressure warning indicator light coming on. Refilled the tires to 26/29 psi. Went for the required 20 minute ride, to reset. Tried this 3 times, the indicator still came on. Was going to take it to the dealer for a fix. Then came across this old post.
Took his advice and adjusted all 4 tires to 40 psi. took the car for a the required ride. Ten minutes later the pressure indicator light went out and stayed out.
Went home and brought down the pressure to 26/29 psi. Indicator warning light no longer comes on. :) Note: the car did ride rough with 40 psi !
 
41 - 51 of 51 Posts
Top