Alfa Romeo 4C Forums banner

1 - 20 of 84 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Tonight my car would not shift into reverse and would only use second fourth and sixth gears. It was saying transmission issue C owners manual. I was wondering if others have had this if so what was it
 

·
Registered
Joined
·
685 Posts
Every time I hear about this issue its seems to be TCU or tranny related. How many miles do you have on the car, year?
 

·
Registered
Joined
·
191 Posts
Have had the same problem, do not know what it is yet, it’s claimed as warranty from my side. Seems like a fairly common problem, hopefully something that FCA will address properly at some stage, but my first impression was denial... my problem cleared itself both times.
 

·
Registered
Joined
·
681 Posts
How is your battery? Some of these newer cars with DCTs need to have a steady current from the battery. A weak battery could cause all kinds of gremlins in modern cars.
 

·
Super Moderator
Joined
·
5,925 Posts
Without a code reader it's all guesswork. Mine's an actuator fault. Any prize for the right guess?
 

·
Registered
Joined
·
185 Posts
Someone chime in if I'm wrong but with a dual clutch tranny, doesn't part of it operate 1,3,5 while the other operates 2,4,6? Is your car under warranty still?
 

·
Registered
Joined
·
681 Posts
How old is your battery? I had lots of transmission gremlins with my previous carrera S that had a PDK transmission. I replaced the battery and problem solved. These dual clutches transmission require a constant volt. If the battery is not 100 percent, issues like this may arise. I’m not saying this is your issue, just a possibility.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #12
No it was up in august but I had it there before that with the transmission doing some weird things but they never could find anything wrong with it and then it kind of went away. It was jumping out of dynamic mode and telling me to look at owners manual quite a few times it did that
 

·
Registered
Joined
·
36 Posts
Discussion Starter #13
Is it safe to drive it while it’s doing this I was wanting to drive it to the shop tonight which is about 40 miles away.
 

·
Registered
Joined
·
794 Posts
When I got into trouble, disconnecting the battery and hooking up again solved the problem for some time. Or get an OBD reader to clear the code. Still, dangerous to have the car no longer shifting on some roads...
 

·
Registered
Joined
·
171 Posts
Tonight my car would not shift into reverse and would only use second fourth and sixth gears. It was saying transmission issue C owners manual. I was wondering if others have had this if so what was it
Have same problem but my 4C 1, 3 ,5 my years 4C 2015 , your?

Inviato dal mio vivo NEX S utilizzando Tapatalk
 

·
Registered
Joined
·
95 Posts
Tonight my car would not shift into reverse and would only use second fourth and sixth gears. It was saying transmission issue C owners manual. I was wondering if others have had this if so what was it
Hello rndmichaels,
We certainly understand why this would be concerning! If you're not able to determine a solution based on suggestions from fellow forum members and you decide to address this with your dealer, please let us know via private message. We would be more than happy to provide you with an additional layer of assistance for that process.
Laura
AlfaRomeoCares
 

·
Registered
Joined
·
110 Posts
I've had a "transmission fault" happen twice so far, and the car has always been in Dynamic + Manual when it occurred. 38k miles on a 2015 LE with an Alfaworks Race ECU and supposedly the previous owner did the transmission flash.

Still trying to figure out how to consistently reproduce the fault. :unsure:
 
1 - 20 of 84 Posts
Top